CloudHealth Platform Increase In Latency
Incident Report for CloudHealth Technologies
Resolved
This incident has been resolved.

Please contact support@cloudhealthtech.com with any questions.
Posted 18 days ago. Oct 03, 2019 - 13:42 EDT
Investigating
We are currently investigating reports of slowness throughout the platform.

Please email support@cloudhealthtech.com if you have any questions.
Posted 18 days ago. Oct 03, 2019 - 12:40 EDT
This incident affected: CloudHealth Platform.