New users may be unable to log into CloudHealth
Incident Report for CloudHealth Technologies
Resolved
Engineering has implemented a fix and this incident is now resolved.

Please email Support@CloudHealthTech.com with any further questions.
Posted May 22, 2020 - 19:28 EDT
Investigating
We are working on an issue where some newly invited users are getting an error and unable to log into the CloudHealth Platform. We will provide additional information as it becomes available. If you have any specific questions, you can contact support@cloudhealthtech.com
Posted May 22, 2020 - 13:22 EDT
This incident affected: CloudHealth Platform and CloudHealth Partner Platform.