Unable to Access CloudHealth Training Academy
Incident Report for CloudHealth Technologies
Resolved
Access to the Training Academy has been restored.
Posted Dec 21, 2021 - 17:11 EST
Identified
CloudHealth is currently partnering with our training platform vendor on resolving an access issue with our Training Academy site.

We will provide a further update as soon as access is restored.
Posted Dec 16, 2021 - 19:25 EST
This incident affected: Training Academy.