CloudHealth Unavailable - HTTP Error 503
Incident Report for CloudHealth Technologies
Resolved
The issue has been resolved. Users will now be able to successfully reach the CloudHealth platform.

Please contact the support team at support@cloudhealthtech.com with any questions.
Posted Jun 19, 2020 - 04:08 EDT
Investigating
Our engineering teams are aware and investigating an issue causing the CloudHealth platform to be currently unavailable. Users will see a HTTP Error 503 page when attempting to load CloudHealth. We are working to fix this as soon as possible.

If you have any questions please reach out to support at support@cloudhealthtech.com
Posted Jun 19, 2020 - 04:04 EDT
This incident affected: CloudHealth Platform.