Delayed AWS Asset Collection
Incident Report for CloudHealth Technologies
Resolved
Normal collection has resumed for all impacted assets. As noted, any short-lived assets from the impacted asset list which were terminated during this period may not be present within the CloudHealth platform.

List of impacted Services -

EC2:
Instances
Volumes
Regions
Reservations
Instance Status
Images
Availability Zones
Reservation MODs
Reservation Listings
NAT Gateways

EMR:
Cluster

S3:
Bucket

IAM:
Users
Groups
MFA:
Policies
Policy Descriptions
Roles
Server Certificates
Credential Report
Generate Credential Report
Password Policy
Policy Versions
Access Keys

CloudWatch Metrics (hourly):
Volumes
Instances
RDS Instances
Load Balancers
Dynamo DB
S3 Buckets

NOTE: Daily CloudWatch Metrics are not impacted.

CloudTrail:
Events
Event Files

Config:
Settings
Rules

Kinesis:
Streams
Stream

Application Discovery Service:
Agents
Servers
Processes
Connections
Server Configurations

If you have any further questions, please contact support@cloudhealthtech.com.
Posted Oct 15, 2020 - 05:46 EDT
Update
Collection for the following Services has now recovered -

EC2:
Instances
Volumes
Regions
Reservations
Instance Status
Images
Availability Zones
Reservation MODs
Reservation Listings
NAT Gateways

EMR:
Cluster

IAM:
Users
Groups
MFA:
Policies
Policy Descriptions
Roles
Server Certificates
Credential Report
Generate Credential Report
Password Policy
Policy Versions
Access Keys

CloudTrail:
Events
Event Files

Kinesis:
Streams
Stream

Application Discovery Service:
Agents
Servers
Processes
Connections
Server Configurations

We will provide a further update as soon as the remaining services are fully recovered.
Posted Oct 15, 2020 - 03:58 EDT
Update
.
Posted Oct 15, 2020 - 03:54 EDT
Monitoring
The CloudHealth platform is experiencing a delayed collection of a subset of AWS Services since approximately 3:30 AM UTC.

While the impacted collection tasks are delayed, some policies evaluating this data may be impacted and not evaluate based on the latest metadata.

Short-lived Assets from the impacted asset list terminated during this period may not be present within the CloudHealth platform.

The collection is in the process of recovery and we will provide a further status update as soon as collection has fully resumed.

List of impacted Services -

EC2:
Instances
Volumes
Regions
Reservations
Instance Status
Images
Availability Zones
Reservation MODs
Reservation Listings
NAT Gateways

EMR:
Cluster

S3:
Bucket

IAM:
Users
Groups
MFA:
Policies
Policy Descriptions
Roles
Server Certificates
Credential Report
Generate Credential Report
Password Policy
Policy Versions
Access Keys

CloudWatch Metrics (hourly):
Volumes
Instances
RDS Instances
Load Balancers
Dynamo DB
S3 Buckets

NOTE: Daily CloudWatch Metrics are not impacted.

CloudTrail:
Events
Event Files

Config:
Settings
Rules

Kinesis:
Streams
Stream

Application Discovery Service:
Agents
Servers
Processes
Connections
Server Configurations

If you have any further questions, please contact support@cloudhealthtech.com
Posted Oct 15, 2020 - 03:38 EDT
This incident affected: CloudHealth Platform.