CloudHealth Platform Limited Availability
Incident Report for CloudHealth Technologies
Resolved
Our engineering team has remediated the issue. Users who were seeing the "Not Authorized" errors are asked to log out and back into the platform to start a new session.
Posted May 26, 2022 - 16:41 EDT
Investigating
The CloudHealth platform is experiencing degraded performance. Customer might experience intermittent issues logging into the platform or get a “Not authorized” error when opening reports.

Our teams are investigating the platform performance and will provide further updates once available.
Posted May 26, 2022 - 13:15 EDT
This incident affected: CloudHealth Platform.