Azure MCA (Azure Plan) duplicate Cost and Usage data from November 1st 2022.
Incident Report for CloudHealth Technologies
Resolved
CloudHealth Engineering has advised that they expect to have correct data for the majority of customers now. The remaining reports should be updated within the next few hours.

Please reach out to support@cloudhealthtech.com if you have any additional questions.
Posted Nov 16, 2022 - 05:06 EST
Monitoring
Microsoft has rectified the Azure plan API issue. CloudHealth Engineering has plans in place to reprocess all affected MCA partner customers. Until that time, we expect all affected customers' Cost and Usage reports to be duplicated for the current month.

Please reach out to support@cloudhealthtech.com if you have any additional questions.
Posted Nov 15, 2022 - 03:29 EST
Investigating
CloudHealth has identified that a number of Azure Partner Customer MCA (Azure Plan) subscriptions are observing duplicate cost and usage data from November 1st 2022.

We are currently partnering with Microsoft to investigate and remediate this issue, and we will provide further updates as the investigation proceeds.

Impacted partner customers can be confirmed by reviewing the Azure Cost History report at a daily interval and confirming if a large increase in cost is observed from November 1st 2022.

Please contact support@cloudhealthtech.com with any questions.
Posted Nov 14, 2022 - 18:52 EST
This incident affected: CloudHealth Platform and CloudHealth Partner Platform.